[Aporte] Saltar la actualización de algunos paquetes en Manjaro

photo_2016-11-21_13-28-42

Hace unos días me instalé el emulador PPSSPP el cual sirve (por si no lo dedujeron) para jugar a juegos de la consola portatil PSP de Sony.

Como hasta el sábado que pasó no tuve tiempo no lo había probado hasta que lo hice y me funcionaba mal.
El problema que tiene el emulador en su versión más reciente, la 1.3-1 es que los juegos que tienen cinemáticas (la mayoría) hacen que el emulador se rompa y no se pueda jugar.

Esto hizo que investigue y en un grupo de Telegram (larga vida a éste mensajero/red social) me pasaron la URL donde están alojados todos los paquetes en sus versiones anteriores para pueda instalar la versión anterior, usar el emulador sin problemas esperando a que salga la nueva versión corregida de la aplicación.

Dicho y hecho, me bajé la versión anterior, la 1.2.2-1 y con un simple “sudo pacman -U <paquete>” instalé el emulador sin problemas.

Ahora, el tema está en que al querer hacer un “sudo pacman -Syu” me salta la actualización del PPSSPP a la 1.3.1, que si la aplico vuelvo a tener el problema, entonces lo que decidí es configurar el paquete para ignorarlo. Los pasos son los siguientes:

  1. Editamos el archivo pacman.conf

sudo nano /etc/pacman.conf

  1. Una vez abierto el archivo vamos a la línea y la descomentamos:

IgnorePkg=NombrePaquete

Obviamente donde dice “NombrePaquete” es el nombre que se usa para instalar la aplicación, es éste caso “ppsspp”.

Lo que va a hacer esto es que cuando querramos actualizar el sistema, salteamos la actualización de éste paquete sin problemas esperando tranquilos a que salga la actualización que lo arregle. Cuando ocurra, se borra la línea editada y listo.

ignorepackage

NOTA: Atención, hacer esto puede generar problemas en el sistema, por lo que se aconseja no hacerlo con paquetes del sistema o aplicaciones importantes donde juega un rol importante en el engranaje del rolling release de Manjaro. Cómo yo estoy haciendo ésto con una aplicación que no toca el sistema e incluso no pertenece a el, ésto se puede hacer sin problemas.

6 thoughts on “[Aporte] Saltar la actualización de algunos paquetes en Manjaro

  1. Marcelo 21 noviembre, 2016 / 6:18 PM

    Si se quiere activar la actualización de/los paquete/s que se han ignorado, bastaría con incluir un signo # al comienzo de la línea, un tanto mas precavido que borrar la línea.

    Si se van a omitir la actualización de varios paquetes, se introducen los nombres de los mismos separados por espacio.

    Saludos.

    Me gusta

    • NeoRanger 22 noviembre, 2016 / 6:52 AM

      Lo decías porque la línea ya se encuentra en el archivo pacman.conf? Bueno si, si se deja comentada cuando querramos dejar de ignorar el o los paquetes si, mejor así no hay problemas. La opción de varios paquetes ignorados no la sabía. Gracias!

      Me gusta

      • Marcelo 22 noviembre, 2016 / 1:40 PM

        Si @Neo, lo decía por eso.

        En Arch, la línea ‘ #IgnorePkg= ‘ ya esta escrita en el archivo ‘ /etc/pacman.conf ‘, ¿En Manjaro no viene así?

        Me gusta

      • NeoRanger 22 noviembre, 2016 / 1:42 PM

        Si, viene así. Ya modifiqué el artículo para que se entienda correctamente. Saludos!

        Me gusta

  2. mitcoes1604 22 noviembre, 2016 / 6:22 AM

    ¿No es mas sencillo usar el comando downgrade tras la actualización?

    Me gusta

    • NeoRanger 22 noviembre, 2016 / 6:50 AM

      Para mi no, porque además vas y venís con el paquete de gusto. Que no lo actualice directamente y listo.

      Me gusta

Dejame un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s